Audio tracks external ouput silent RME audio interface [SOLVED]

Discuss working with MultitrackStudio for iPad
Post Reply
Reloud
Posts: 4
Joined: Fri Nov 18, 2022 9:13 pm

Audio tracks external ouput silent RME audio interface [SOLVED]

Post by Reloud » Fri Nov 18, 2022 11:38 pm

EDIT: solved, solution in the last post.

Hi there,

Just bought MTS with its Pro extension 🚀 so far very interesting!

Question:
Main output is 1/2 and works well. However, when assigning an audio track to 3/4 (to an external compressor), no signal is received on the compressor.

Having the same exact setting (audio track to 3/4 output) works correctly with other iPad DAWs.

Moreover, if I go in the Device setting pane, and switch “Audio outputs” to 3/4, 5/6, 7/8, etc (I have up to 17/18), all tracks going to “master” are silent and surprisingly, there is a sound on my main speakers only when audio tracks are set to 3/4 outputs… even when I select 17/18 in the “device” pane. I tried all the combinations and only 3/4 works as an output to my main speakers. Pretty weird.

Am I missing something here or is it a bug?

My audio interface is an RME fireface UCX set as class compliant (works well with other apps).

Hope I can get help with that.
Cheers!

Support
Posts: 1631
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Audio tracks external ouput silent

Post by Support » Sat Nov 19, 2022 7:32 pm

Are your tracks playing back, or are they recording using the Mon button (at the top of the screen)?


Giel Bremmers

Reloud
Posts: 4
Joined: Fri Nov 18, 2022 9:13 pm

Re: Audio tracks external ouput silent

Post by Reloud » Sun Nov 20, 2022 1:37 am

The tracks are playing back (PLAY button in green).

Recap:
- I have an audio track with audio content in it. I want to send the output to my external compressor, connected to my audio interface 3/4 outputs.
- Instead of MASTER, I select CH 3/4 as the output of the track. But nothing is going into my external compressor
- The track has the PLAY button in green
- Mon is not activated.

I did created a stereo track with REC being Channel 3/Channel 4, (to get the output of my compressor back into MTS), but nothing goes in it since there is no signal being sent in my external compressor in the first place.
If instead of Channel 3/channel 4, I select Output 3/4, I can record the first audio track that I want to send to my compressor. But it is not what I want to do, I don’t want to do internal sampling in this case.

I am available for any further information needed! I hope we can find a solution.

Thank you

Support
Posts: 1631
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Audio tracks external ouput silent

Post by Support » Sun Nov 20, 2022 9:59 am

Thanks for the info.
I can't reproduce the problem with the 4 channel device I have: sending a track to channel 3/4 works as expected.
Could you please send a report, so I have more info? Please see Studio-->Contact.
Reloud wrote:
Fri Nov 18, 2022 11:38 pm
Moreover, if I go in the Device setting pane, and switch “Audio outputs” to 3/4, 5/6, 7/8, etc (I have up to 17/18), all tracks going to “master” are silent and surprisingly, there is a sound on my main speakers only when audio tracks are set to 3/4 outputs… even when I select 17/18 in the “device” pane. I tried all the combinations and only 3/4 works as an output to my main speakers. Pretty weird.
TLDR:
Just leave it at "Channel 1 + 2" and don't worry.

Full story:
The desktop version has a list of outputs. The user can re-order the list. See https://multitrackstudio.com/asio.php (end of page).
Something like "Ch. 3/4" in a track output selector means "line 3 and 4 of the list" rather than "jack 3 and 4 of the audio device".

The iPad version's Studio-->Devices-->Audio Output Channels setting effectively puts the selected channels at the top of said list. So that's where the master output is sent to. If you select anything other than "Channel 1 + 2" the first stereo output of your device will be at position 3 and 4 of the list. In your case this will map Ch 3/4 to your speakers.


Giel Bremmers

Reloud
Posts: 4
Joined: Fri Nov 18, 2022 9:13 pm

Re: Audio tracks external ouput silent

Post by Reloud » Sun Nov 20, 2022 1:01 pm

Superb, thank you for your help, I’m follow up with an email to support.

Cheers 👍

Support
Posts: 1631
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Audio tracks external ouput silent

Post by Support » Sun Nov 20, 2022 8:14 pm

Thanks for the report. Everything looks fine, and further attempts to reproduce the issue failed. :?

Does the RME fireface UCX have other class compliant modes? If so, did you try them?


Giel Bremmers

Reloud
Posts: 4
Joined: Fri Nov 18, 2022 9:13 pm

Re: Audio tracks external ouput silent

Post by Reloud » Tue Nov 29, 2022 3:26 pm

Hello Giel,

Thank you so much for your support.

Your suggestion to check other Class Compliant modes for my RME Fireface UCX did the trick actually ;). I’ve finally managed to use external outputs with MTS. Here is the walkthrough for other people in the same situation:

- Make sure the the audio interface is ON and connected to the iPad
- Launch TotalMix app
- In the settings (top right icon) -> RME Interface Settings -> Output Channel Count Req. is « No preference » by default. Set it to « Multichannel »
- Set MTS song as multichannel
👍

You don’t have to do that all the time luckily.

For Giel: what is surprising is that some apps on the iPad always work whether the RME option is correctly set or not. I would guess maybe there is something to « force » this Multichannel option on the audio interface.

Thank you for the reactivity and your support!

Support
Posts: 1631
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Audio tracks external ouput silent

Post by Support » Tue Nov 29, 2022 9:52 pm

Nice!
Reloud wrote:
Tue Nov 29, 2022 3:26 pm
For Giel: what is surprising is that some apps on the iPad always work whether the RME option is correctly set or not. I would guess maybe there is something to « force » this Multichannel option on the audio interface.
Yeah, that's strange indeed.


Giel Bremmers

Post Reply