Broken AU and IAA support

Discuss working with MultitrackStudio for iPad
Post Reply
Ralf
Posts: 20
Joined: Wed May 20, 2020 2:40 pm

Broken AU and IAA support

Post by Ralf » Fri Jul 03, 2020 9:16 am

Hi,

when can we expect an update addressing the top topics, ("Confusion with recording inter-app plugins?",
"AUi3 Midi Issue with iSymphonic after a year of working well")?

On my iPadPro only a few AU synths can be used, other cause under runs already at minimal load or won't run at all. IAA synths don't produce a sound at all, even when trying workarounds such as starting a synth at half moon and after that MTS Studio at full moon.

I don't expect everything to work, but at least a variety off synths that cover what's minimal needed to produce any kind of music. It's not the case now, while probably a lot of the important synths are installed on my iPadPro and most of them are working when loaded by other hosts.

iPad Pro (12.9-inch) (3rd generation)
Model MTFR2FD/A A1876
iPadOS 13.5.1
MTS Studio 3.8.1 + Pro Extension + Track Pack

My iPads apps as of 2020-07-01 (full size):
Image

There should be no need for all of us to sent reports related to issues affecting not just a minority. We bought the app to get things done, not to become testers.

Regards,
Ralf

Moozeeck
Posts: 42
Joined: Fri Jun 15, 2018 7:49 pm

Re: Broken AU and IAA support

Post by Moozeeck » Fri Jul 03, 2020 12:57 pm

Ralf wrote:
Fri Jul 03, 2020 9:16 am
There should be no need for all of us to sent reports related to issues affecting not just a minority. We bought the app to get things done, not to become testers.
Regards,
Ralf
Giel Bremmers is a professional and very supportive developer that listens to customers and reacts immediately upon issues with MTS, to me personally he helped many times, and I saw helping others with fixes, I have no doub't that he will solve your problem, there is no need for harsh words.

Support
Posts: 1484
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Broken AU and IAA support

Post by Support » Fri Jul 03, 2020 1:24 pm

Please report issues you have, mentioning the AU plugin and what the problem is.

I'm not aware of significant AU issues other than these two:

1. The iSymphonic issue you linked to. This appears to be an iOS issue. I confess that I haven't spent too much time on this yet.

2. A user reported timing inaccuracies with some AU MIDI effects when using "apply to track". I haven't been able to reproduce this (even after spending a significant amount of time on it).


Regarding IAA: Apple has deprecated IAA, so I consider AU problems to be much more important.


Giel Bremmers

Ralf
Posts: 20
Joined: Wed May 20, 2020 2:40 pm

Re: Broken AU and IAA support

Post by Ralf » Fri Jul 03, 2020 3:24 pm

At the moment I can't spend much time in reporting issues, since I must finish my work. However, at least Oriental Strings, iSymphonic and
Heavy Brass from Christian Schoenbeck, aka Crudebyte don't work as AU plugins with MTS Studio. At least FM Player 2 from the AudioKit family does cause that many buffer underruns, that it can't be used.

If IAA would work, it could be used as a workaround for AU synths that fail to work as AU, but do support IAA, too. Actually Oriental Strings also fails to work with MTS Studio as a IAA plugin, while this e.g. works with Cubasis 3. Some synths support IAA only and those synths might provide features required for a song, that I usually would use by other synths supporting AU, if it wouldn't fail to work.

Since IAA still does exist, it would be good, if it would work, even while I agree that AU is way more important.

I'm aware that Apple can be the cause of issues, "JACK has been removed by Apple" comes into mind, let alone things that work on small and/or old iPads, that stopped working on an iPadPro.

Btw. the lists of AU apps available (working or broken) already differs a lot between different hosts, but they might be available as IAA plugin. If I open different hosts on the same iPad, I see different lists of available AU apps.

Support
Posts: 1484
Joined: Fri Aug 27, 2004 2:17 pm
Contact:

Re: Broken AU and IAA support

Post by Support » Sat Jul 04, 2020 9:55 am

Ralf wrote:
Fri Jul 03, 2020 3:24 pm
Oriental Strings, iSymphonic and Heavy Brass from Christian Schoenbeck, aka Crudebyte don't work as AU plugins with MTS Studio.
Did you get the latest updates for those apps? Looks like they've been updated a couple of days ago to fix the issue that made them crash in MTS/iOS 13.4.1.


GIel Bremmers

Ralf
Posts: 20
Joined: Wed May 20, 2020 2:40 pm

Re: Broken AU and IAA support

Post by Ralf » Sun Jul 05, 2020 11:43 am

I can't comment on iOS 13.4.1, since I'm not using iOS at all. The iPad Pro is up-to-date on iPadOS 13.5.1. All apps are up-to-date. Using the Oriental Strings 2.0.8 audio unit with Cubases 3.1.1 works at least for a short test and likely also for a real production. It does not work at all with MTS Studio 3.8.1.

Post Reply